CẤU HÌNH VLAN TRÊN SWITCH LAYER 3

Mục đích: C3750 đã định tuyến đường giữa các VLAN, Router 1841 chỉ có trách nhiệm kết nối mạng internet cho tổng thể mạng Lan

Cấu hình:

Switch 3750:


Cấu hình VLAN bên trên 3750:

Switch3(config)#vlan 2Switch3(config-vlan)#name KeToanSwitch3(config-vlan)#exitSwitch3(config)#vlan 3Switch3(config-vlan)#name NhanSuSwitch3(config-vlan)#exitSwitch3(config)#vlan 4Switch3(config-vlan)#name KinhDoanhSwitch3(config-vlan)#exitSwitch3(config)#

Gán vlan đến từng interface:

Switch3(config)#int f0/1Switch3(config-if)#switchport access vlan 2Switch3(config)#interface f0/2Switch3(config-if)#switchport access vlan 3Switch3(config)#int f0/3Switch3(config-if)#switchport access vlan 4Switch3(config-if)#exitSwitch3(config)#

Cấu hình mang lại Router C1841:

Building configuration…

Current configuration : 959 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.253 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Cấu hình mặt đường ngược lại cho những vlan

ip route 192.168.2.0 255.255.255.0 FastEthernet0/1

ip route 192.168.3.0 255.255.255.0 FastEthernet0/1

ip route 192.168.4.0 255.255.255.0 FastEthernet0/1

!

no ip http server

ip nat inside source danh mục 1 interface FastEthernet0/0 overload

!

access-list 1 permit any

!

control-plane

!

!

line nhỏ 0

line aux 0

line vty 0 4

login

!

end

Kiểm tra cấu hình vlan:

*

Show thông số kỹ thuật ip routing, tại chỗ này do chưa nối với Switch 0, 2 nên chưa có 2 mạng kia: